Resolved
Your Co-op data has now been processed and applied to your SKUtrak service
Investigating
We are experiencing an issue with our data processing infrastructure, which will delay updates to your Co-op service. We are investigating the cause of the issue and will provide a further update once we have more information.