Resolved
We have received fully updated data from Morrisons, covering up to and including the latest date, which has been processed to your SKUtrak service.
Identified
Morrisons have advised that the generation of their data has been delayed. We will receive a notification once the data has been produced and will update once processing has started.