Data Processing Delays - SKUtrak service impacted
Incident Report for SKUtrak
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 10:10 BST
Identified
We are experiencing an issue with our data processing infrastructure which has caused delays in updating your Waitrose service. We have investigated and identified the cause of the problem, we are working on a fix at the moment and we will update you as soon as we know more
Posted Sep 19, 2024 - 09:47 BST
This incident affected: SKUtrak Application (Data Processing).