Data Processing Delays - Morrisons SKUtrak service impacted
Incident Report for SKUtrak
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 11:25 BST
Investigating
We are experiencing an issue with our data processing infrastructure which will cause delays in updating your Morrisons service. We are investigating the cause of the issue and will provide a further update once we have more information.
Posted Sep 26, 2024 - 10:47 BST
This incident affected: SKUtrak Application (Data Processing).